Yii2 basic: Ошибка You should configure authManager component to use database before executing this migration.

       Yii2      yii2    rbac    migration yii2      577    

При реализации миграции (во время настройки RBAC) часто возникает ошибка You should configure 'authManager' component to use database before executing this migration.

Она говорит нам о необходимости настроить компонент «authManager» для использования базы данных перед выполнением этой миграции.

Для этого добавим в конфигурационные файлы (/config/web.php и /config/console.php) следующую настройку:

'components' => [
  'authManager' => [
    'class' => 'yii\rbac\DbManager'
  ]
]
Комментарии временно оключены

Поиск

Популярное